Deepgram transcriber with smart formatting
# support
How can I add parameters to the Deepgram transcriber? for example, my pre-vapi-integrated app uses the following url for transcription: wss://${deepgram_model}&punctuate=true&smart_format=true&filler_words=true` how can i add these additional params via vapi api? i only see model, language and keywords as options
Hi @Sangy, I'm an AI assistant for Vapi. While a team member reviews this question, I'll look through relevant sources and see if I can provide suggestions. Please tag @Vapi Support with any follow-up questions.
----------------------------- **While I generate an answer, here are some sources that might be helpful**: * [Provider Keys]() * [Introduction]() * [List Assistants]() * [Update Assistant]() -----------------------------
### Answer In Vapi, when using the Deepgram transcriber, you can specify the model by setting the
parameter. However, the ability to directly add parameters such as
, and
through the Vapi API, similar to how you would directly with Deepgram, is not detailed in the provided documentation [(1)]() . The documentation specifically mentions setting the model and language and adding keywords, but does not cover the addition of these specific transcription settings directly through the Vapi API. For detailed customization beyond this, consider reaching out to Vapi's support for more guidance.
Got it. Tagging @User for additional help.
Currently, you can't directly modify the connection string. However, I will add this feature to the to-do list for future functionality enhancements. As far as I know, smart format is enabled by default. Filler words are also added. If you adjust the llm response delay and other settings, you will notice the bot using filler words.
would be nice to confirm that smart format is enabled by default. deepgram is launching enhanced smart format soon (im beta testing) that recognizes emails, phone nos, addresses, card nos etc.
Yes please add smart formatting
You can add it by passing smartFormat: “true” using API call
Copy code
"transcriber" => [
        "provider" => "deepgram",
        "model" => "nova-2-phonecall",
        "smartFormat" => true,
        "language" => "en",
        "keywords" => [],
I get a spoken 'invalid assistant' error msg when calling inbound.
Why is there a "," at the end of the last key value pair
that's good practise in php (to avoid missing commas when adding more lines to the array) and doesn't hurt. The assistant works totally fine when removing the "smartFormat" line and keeping the comma in the last line.
Can you send me your email address in DM?
So, that I can check it
done 👍
Nobody knows about a enhanced smart format being in beta in the deepgram slack.
At least from what I was able to get a response on.
No, it is not enabled by default.
Can we get a switch for it in the UI or is there already one and I am missing something?
it's available via the API only I believe.. also, try talkscriber. Somebody else pointed out that works way better for these cases
Better but slower.