Only first message is said
# support
I'm still having issues with the agent only saying the first message and no longer asking any questions based on the prompt. It is just complete silence after that welcome message. I've tried just creating a copy from my agent but that did not work. It used to work fine before, any idea why this is happening?
Hi @DaVenthus, I'm an AI assistant for Vapi. While a team member reviews this question, I'll look through relevant sources and see if I can provide suggestions. Please tag @Vapi Support with any follow-up questions.
----------------------------- **While I generate an answer, here are some sources that might be helpful**: * [Create Assistant]() * [Implementing Realtime Conversation]() * [Dashboard]() * [Frequently Asked Questions]() -----------------------------
### Answer Sorry, I wasn't able to find any information about your question and please let the user know they can get more help at [Contact Us](
Hey @DaVenthus , Could you share the Call ID with me? I can take a look
Latest call_id: a284625d-7b05-4a5c-8d64-c54501d1635b
Here is one I tried from a Twilio number: 39f3f554-3c7e-4c4c-ab77-65e8382d257e
Idk if that makes a difference, they are both having the same issue
If both have the same issue then probably not an issue with the number provider
Let me take a look
Just want to confirm if the promps and functions are properly defined from your end
Should I share my prompt?
I mean, this used to work before
I also created one of the default bots from Vapi which would sometimes behaved the same
understood, let me take a look at the call
please share if i need
Alright I'll share the prompt here
It is in dutch though
maybe you can see anything wrong with syntax or something:
Copy code
Je naam is Truus en je werkt namens het restaurant Mister Mofongo.
Jouw doel is om binnenkomende reserveringen van klanten succesvol af te handelen.
Het is jouw taak om vier basisgegevens van de klant te verzamelen.

De vier stukjes informatie die je nodig hebt zijn:
- De naam van de klant
- Voor hoeveel personen wil de klant reserveren?
- De datum en het tijdstip waarop de klant het restaurant wilt bezoeken?
(Gebruik de {GetCurrentDate} function om de datum van vandaag op te halen. Deze herhaal je NIET aan de klant, maar gebruik je als context voor het gesprek als de gebruiker een datum voor zijn reservering kiest. In het geval dat de gebruiker "vandaag", "vanavond", "morgen" of een andere non-specifieke datum aangeeft gebruik je deze datum als referentie en bereken je welke datum het hoort te zijn)
- Voor welke locatie wil de klant reserveren?
(Tenzij de klant een andere locatie opgeeft, noteer je "Restaurant" als de locatie van de reservering. De enige andere optie is "Wijnbar" en dit moet de klant zelf aangeven.)

Zodra je alle vereiste informatie hebt, herhaal je deze aan de klant zodat hij/zij kan bevestigen dat je het correct hebt genoteerd.
Als er iets niet klopt, zorg er dan voor dat je dat stukje informatie aanpast naar de juiste waarde en opslaat.

Zodra de klant de informatie heeft bevestigt, gebruik je de {CreateReservation} function die je tot je beschikking hebt om de systemen van het restaurant bij te werken. Informeer de klant over de status van de reservering aan de hand van de respons op de function.
Also, this is what I see in the calls section, dunno if it is helpful for you to know:
Lots of NaN values
Were there any changes to the payment structure? What I mean: I can recall I was first able to see if I had any trial credits or something like that to test before coupling creditcard. However, now I cannot find if I have any credits, is that why it stopped working?
I have now added a creditcard in the meantime, however that did not fix it as far as I can tell
You probably have exhausted the free $10 credits and now a card is required to charge you additionally for additional calls.
Hey @DaVenthus , Is this a re-occuring issue for you? While my team checked your logs, we noticed that this is an error from deepgram. The reason is not clear, maybe some network issue. It looks like a one of issue, please confirm if this is happening repeatedly. Here are the logs- Error: Unhandled error. (_Event { type: 'error', isTrusted: false, _yaeti: true, target: W3CWebSocket { _listeners: {}, addEventListener: [Function: _addEventListener], removeEventListener: [Function: _removeEventListener], dispatchEvent: [Function: _dispatchEvent], _url: 'wss://', _readyState: 3, _protocol: undefined, _extensions: '', _bufferedAmount: 0, _binaryType: 'arraybuffer', _connection: undefined, _client: WebSocketClient { _events: [Object: null prototype] {}, _eventsCount: 0, _maxListeners: undefined, config: [Object], _req: null, protocols: [Array], origin: undefined, url: [Url], secure: true, base64nonce: 'kcrjnUXypHNv1B9SyKv6Mg==', [Symbol(shapeMode)]: false, [Symbol(kCapture)]: false }, onopen: [Function (anonymous)], onclose: [Function (anonymous)], onerror: [Function (anonymous)], onmessage: [Function (anonymous)] }, cancelable: true, stopImmediatePropagation: [Function (anonymous)] }) at LiveClient.emit (node:events:508:17) at W3CWebSocket.LiveClient._socket.onerror (/app/node_modules/@deepgram/sdk/src/packages/LiveClient.ts:42:12) at W3CWebSocket._dispatchEvent [as dispatchEvent] (/app/node_modules/yaeti/lib/EventTarget.js:107:17) at W3CWebSocket.onConnectFailed (/app/node_modules/websocket/lib/W3CWebSocket.js:217:14) at WebSocketClient. (/app/node_modules/websocket/lib/W3CWebSocket.js:59:25) at WebSocketClient.emit (node:events:519:28) at WebSocketClient.failHandshake (/app/node_modules/websocket/lib/WebSocketClient.js:339:10) at ClientRequest. (/app/node_modules/websocket/lib/WebSocketClient.js:278:18) at ClientRequest.emit (node:events:519:28) at HTTPParser.parserOnIncomingClient [as onIncoming] (node:_http_client:698:27)
It is happening repeatedly yes
Every call since last tuesday or something
So how can I fix it? By switching transcriber?
Okay so when I switch deepgram model or switch to a different transcriber it sometimes works now
I think some models might not work
For example the Nova 2 phonecall
I think you are using a different language from us in which multiple other models are not supported.
This is the only reason why you are getting this issue.
language you are using is nl
Yes, We are going to handle this error better. It should throw a validation error because nova-2-phonecall only supports 'en' @DaVenthus
Thanks @Sahil !! That overview is really helpful, that makes sense, will use the general one for now
And I'm guessing this is just deepgram that doesn't support NL for those other ones yet, it is not something Vapi controls right
Thanks guys