URGENT SUPPORT PLEASE -customer-did-not-give-micro...
# support
Hi there, I've set up Vapi using the voice widget. Everything's been working perfectly for the past few months but then suddenly my users aren't able to connect. The widget keeps "connecting" without actually connecting to the call. on Vapi under call log it says "customer-did-not-give-microphone-permission". I'm confused because nothings changed on my end? Any ideas??
Hi @araSh, I'm an AI assistant for Vapi. I'll analyze available sources and get back to you shortly.
----------------------------- **While I generate an answer, here are some sources that might be helpful**: * [Call Ended Reason]() * [Voice Widget Example]() * [Create Phone Call]() * [Get Call]() -----------------------------
### Answer The issue you're experiencing, indicated by the "customer-did-not-give-microphone-permission" message, suggests there may be a problem with the microphone permissions on your users' end. This message indicates that the user did not grant permission for the microphone to be used during the call, which is essential for Vapi's voice widget to function properly [(1)]() . Here are a few steps you can take to troubleshoot and potentially resolve this issue: 1. Verify Browser Permissions: Ensure your users are prompted to allow microphone access when using the voice widget. Users should check their browser's address bar for a microphone icon or permission prompt. 2. Check Widget Implementation: Review the implementation of the Vapi voice widget on your site to ensure it's correctly set up as per the documentation. Incorrect widget setup might lead to unexpected behaviors [(2)]() [(3)]() . 3. Test Across Different Browsers: Sometimes, browser-specific issues can cause permission problems. Ask your users to try accessing the voice widget using a different browser to see if the issue persists. 4. Review Recent Changes: Even if you believe nothing has changed on your end, it's worth reviewing any recent updates or modifications to your website that might inadvertently affect how permissions are handled. If these steps do not resolve the issue, consider reaching out to Vapi's support for further assistance, as they might need to look into more specific details of your setup.
Did the user provided the microphone permission and is it happening to all the users?
Hi Sahil! Yea, that's not the issue. It has been working perfectly for months and suddenly stopped... I copied the html out of bubble (which is where we are building) and put it onto a random wordpress page and it worked... Still don't understand how to fix my bubble site.
This is my console
DOMException: Failed to execute 'postMessage' on 'Window': Invalid target origin 'null' in a call to 'postMessage' This is the message that appears everytime I click the button
@araSh Can you share this code so that I can reproduce it?
The thing is though, I've reproduced in Wordpress and it worked perfectly
Please share this in DM.