End of call report data received to webhook every ...
# support
I set up a custom webhook in Make.com and put the webhook link into the server url in the 'advanced' settings of the assistant I'm using. When I make a call, data appears to be sent to the server url every couple of seconds. Only the very last call to the webhook url contains the complete summary and transcript. Am I doing something wrong, or is there something wrong with Vapi's end of call report or Make.com?
Hi @JM, I'm an AI assistant for Vapi. While a team member reviews this question, I'll look through relevant sources and see if I can provide suggestions.
----------------------------- **While I generate an answer, here are some sources that might be helpful**: * [Create Assistant]() * [Update Assistant]() * [List Assistants]() * [Set up your Server URL]() -----------------------------
### Answer It sounds like you're encountering behavior related to how Vapi sends messages to your server URL during a call. Vapi communicates with your server URL via HTTP POST requests for various reasons, including status updates, function calls, and the end-of-call report [(1)]() . The frequent messages you're receiving could be status updates or other intermediate messages rather than the end-of-call report. The end-of-call report specifically is sent once the call ends, containing a summary, transcript, and other call details. This report is what you're seeing as the last call to your webhook. This behavior is expected as part of Vapi's operation to keep your server informed about the ongoing call's status and any relevant events. If you're only interested in the end-of-call report, you may want to implement logic on your server or within your Make.com scenario to specifically handle or filter for these reports, ignoring intermediate messages if they're not relevant to your use case.
Got it. Tagging @User for additional help.
bro just go to advanced settingg and disable the other messages there and only send end of call report to your webhook
adding a screenshot of that option. Might be worth mentioning that this option only becomes visible AFTER entering a Server URL on the assistant...
Remove all the other server messages option. After that you won’t get that many requests
Glad I could be helpful. Feel free to create a new thread with any new questions you may have.