Custom voices from 11labs not working
# support
Hi!, new here, I tried to make a new Assistant, I connected my 11labs account, but the custom voices don't work (no sound when tried to "Talk to assistant") and the rest of the voices of 11labs wont work either after connecting my account. The assistant works with other voice providers. assistant id: f8372784-897f-4006-9b42-ac37a26ff1ef
Hi @Carlos, I'm an AI assistant for Vapi. I'll analyze available sources and get back to you shortly.
----------------------------- **While I generate an answer, here are some sources that might be helpful**: * [Web]() * [Dashboard]() * [Inbound Calling]() * [Create Assistant]() -----------------------------
### Answer It sounds like you're encountering a common issue when integrating custom voices from external providers like Eleven Labs into your Vapi assistant. One possible cause for this issue is related to the configuration of your 11labs account or the provision of API keys. According to a user's experience shared on a Discord forum, ensuring your 11labs API keys are correctly added to the "Provider Keys" section in the Vapi dashboard can resolve similar problems. This is mentioned in a conversation where a user faced an error and resolved it by correctly adding their 11labs ID and API keys [(1)]() . When using custom voices, including those from Eleven Labs, it's crucial to ensure that: 1. Your Eleven Labs account is correctly connected. 2. Your custom voice ID is correctly specified in the assistant configuration. 3. Your Eleven Labs API keys are correctly configured in the Vapi dashboard under the "Provider Keys" section. For reference on how to specify a custom voice in your assistant's configuration, here's how you would generally do it, replacing
with your actual custom voice ID from Eleven Labs:
Copy code
  "voice": {
    "provider": "deepgram",
    "voiceId": "your-voice-id"
[(2)]() If you've ensured all the above and the issue persists, it might be due to a specific compatibility or configuration issue with Eleven Labs. Unfortunately, without direct insights into the error logs or the specific configuration details, I can only suggest ensuring all settings are correctly applied as mentioned. For more detailed debugging, reviewing any error messages or logs provided by Vapi when attempting to use the custom voice could offer more insights into what might be going wrong. Remember, the usage of custom voices and ensuring they function as expected can involve checking multiple points of configuration both within Vapi and with the voice service provider.
Got it. Tagging @User for additional help.
check the credits
of 11 labs
You need paid one.
that was the issue, thanks!